Главная » Хабрахабр » [Из песочницы] Уязвимость Mikrotik позволяет получать список всех пользователей через winbox

[Из песочницы] Уязвимость Mikrotik позволяет получать список всех пользователей через winbox

Но и ошибки в программном обеспечении никто не отменял. Устройства компании Mikrotik стали широко распространены из-за своей цены по отношению к функционалу. И на этот раз вылез серьёзный баг.

25 марта один из пользователей форума Mikrotik сообщил об обнаружении подозрительной активности маршрутизаторов mikrotik с применением портов telnet (TCP port 23), TR-069 (TCP port 7547) и WINBOX (TCP 8291).

В последствии выяснилось, что это новая уязвимость и 23 апреля компания Микротик сообщила о выпуске прошивок, где эта уязвимость устранена. Сотрудники компании сослались на баг, который был закрыт год назад.

Несмотря на то, что компания довольно оперативно выпустила bugfix, устройства, подверженные уязвимости в сети исчисляются тысячами.

40. Всем пользователям RouterOS рекомендую обновиться минимум до версий 6. 42. 8 [bugfix] или 6. 1 [current]

Так же в общем доступе появились инструменты, которые позволяют простым пользователям получить доступ на устройства, которые не защищены фаерволом либо не обновлены до актуальной версии.

Ввиду последних событий я предлагаю всем пользователям устройств Mikrotik и CHR произвести хотя бы минимальную настройку.

Минимальные настройки безопасности

И 90% устройств имеют учётную запись "admin" с полными правами. Анализируя устройства с багом, я обратил внимание, что практически все пренебрегают настройками фаервола, несмотря на то, что это самый эффективный инструмент защиты Вашей сетевой инфраструктуры. Прям мечта для брудфорсеров.

В отношении защиты RouterOS сделайте несколько несложных шагов, чтобы обеспечить минимальную безопасность:

  1. Убедитесь, что у Вас последняя прошивка.

  2. 1. Не стоит надеяться на отсутствие багов в новой прошивке и настройте фаервол:
    2. Например, диапазон домашней сети или ip адресами сетевых администраторов.
    Обратите внимание на то, что цепочка INPUT применяется только для пакетов, адресованных непосредственно этому маршрутизатору. В цепочке INPUT доступ к устройству разрешён, только с доверительных ip адресов. 2. Транзитные пакеты относятся к цепочке FORWARD.
    2. 3. Дропайте все пакеты, которые не соответствуют разрешённым.
    2. В случае, если Вам требуется периодически доступ с динамических адресов, то используйте "port knocking", чтобы добавить Ваш ip в разрешённые на определённое время.

  3. Выключите все сервисы, которые Вы не используете (api,ssh,telnet etc.)

  4. После настройки фаервола и обновления прошивки смените пароль.

Также, если вы используете имя учётки "admin" так же создайте свою и заблокируйте "админа".

FireWall

168. С использование терминала.
Создайте список адресов, которым будет разрешено подключаться к маршрутизатору
/ip firewall address-list
add address=192. 0/24 list=allow-ip
add address=192. 1. 88. 168. 10/32 list=allow-ip

Добавляем правило, которое разрешает все действия с этих адресов

/ip firewall filter
add action=accept chain=input comment="Allow Address List" src-address-list=allow-ip

Если такой пакет прилетает, то адрес источника добавляется в список allow-ip со временем в 1 час. В случае если нужен доступ с неизвестных адресов я делаю ожидание icmp пакета (ping) определённого размера. При желании можно сделать каскад из таких пакетов.

/ip firewall filter
add action=add-src-to-address-list address-list=allow-ip address-list-timeout=1h chain=input packet-size=783 protocol=icmp

Но при пинговании Вы должны указывать на 28 байт меньше. Обратие внимание на размер пакета packet-size 783 байт. В данном случае пинг из windows:

ping -l 755 myhostname.domain

Запрещаем доступ ко всем портам, которые не разрешены выше:

/ip firewall filter add action=drop chain=input

Сервисы,

которые Вы не используете тоже надо выключить ибо это лишние точки отказа.
/ip service
set api disabled=yes
set api-ssl disabled=yes
и так далее.

Тоже самое при помощи винбокс.

Разрешаем в нашем адрес листе.

Правило добавления в адрес лист по пингу

Правило запрета всего и вся ставится самым последним

То есть это должно выглядеть так

Сервисы настраиваем здесь

Пользователей добавить и удалить "admin", а также сменить пароль можно здесь

Заключение

Очень надеюсь, что моя краткая инструкция поможет вашему устройству не попасть под контроль любой ботнет сети, в том числе Hajim.


Оставить комментарий

Ваш email нигде не будет показан
Обязательные для заполнения поля помечены *

*

x

Ещё Hi-Tech Интересное!

Что мы узнали о безопасности Intel ME за последние годы: 7 фактов о таинственной подсистеме

Изображение: Unsplash Эту технологию окружает ореол таинственности – несмотря на то, что она имеет доступ практически ко всем данным на компьютере и ее компрометация позволяет захватить полный контроль над машиной, официальной документации и руководств по работе с ней от производителя ...

Орден куколки

Прошу считать пятничным постом! Это как бы научная фантастика, но правда важный дисклеймер 1. Научная фантастика понятие очень широкое. Этот рассказ-эссе я смею предложить только тем, кто нормально относится к углу . Простите меня, если в вашем представлении научная фантастика ...